给你的 WordPress 更新加个代理提升更新稳定性

  • A+
所属分类:WordPress

今天 WordPress 4.9更新推送了,早上明月就看到推送,因为担心兼容性问题就没有更新,没有想到晚上回到家想更新的时候缺总是出现“闲置超时”的错误提示,要不就是出现“另一个更新正在进行”的问题(此问题解决可参考【在线升级WordPress时提示 另一更新正在进行的解决办法】即可。)。

给你的 WordPress 更新加个代理提升更新稳定性

 

其实出现这些问题归根结底就是 WordPress 默认的自动更新调用请求的downloads.WordPress.org服务器是在国外造成的,在国内自动升级WordPress的话会非常慢甚至超时失败。某位站长在国外服务器架设了一台代理服务器,可以直接拿来用,由于代理服务器限制了只能代理WordPress.org域名,使用完后请注释掉代码,以免影响WordPress使用。

  • 解决方法

打开网站根目录的wp-config.php,在底部增加如下代码:

  1. define('WP_PROXY_HOST', 'us.centos.bz');
  2. define('WP_PROXY_PORT', '31281');

保存之后登录WordPress后台,切换到更新,点击升级按钮开始更新。

更新完成后请注释掉刚才加的代码,即在前面添加//,如:

  1. //define('WP_PROXY_HOST', 'us.centos.bz');
  2. //define('WP_PROXY_PORT', '31281');

下次需要升级时再删除注释。

明月使用了这个代理后,马上就可以在 WordPress 后台里正常的更新 WordPress 到4.9版了,可以说是个很好的解决 WordPress 更新故障的好办法,就是大家一定要记得更新完成后要注释掉哦,要不会影响到 WordPress 的正常使用的,这个代理就是 WordPress 更新失败是的一个临时终极解决方案而已!

weinxin
我的微信
这是我的微信

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: