编译安装OpenResty

  • A+
所属分类:系统运维

%ignore_pre_1%

 

1.安装OpenResty所需依赖的包
# yum install readline-devel pcre-devel openssl-devel

 

2.下载OpenResty
# wget https://openresty.org/download/ngx_openresty-1.7.10.2.tAR.gz

 

3.解压、编译、安装:
# tAR xzvf ngx_openresty-1.7.10.2.tAR.gz
# cd ngx_openresty-1.7.10.2/
# ./configure --with-luajit
# make && make install

 

另外的配置选项:
./configure --prefix=/opt/openresty
--with-luajit
--without-http_redis2_module
--with-http_iconv_module
--with-http_postgres_module
 
--help to see more options

 

可能出现的问题:

   ./configure: error: ngx_postgres addon was unable to detect version of the libpq librARy.
  ERROR: failed to run command: sh ./configure –prefix=/opt/openresty/nginx /…

       安装:postgresql-devel

        # yum install  postgresql-devel

 

后续我会发一些关于OpenResty承载web访问统计的文章。

版权属于:
小白的运维站

原文地址:
http://www.52yunwei.cn/?p=415

转载时必须以链接形式注明原始出处及本声明。




该文章由WP-AutoPost插件自动采集发布

原文地址:http://www.52yunwei.cn/?p=415

weinxin
我的微信
这是我的微信

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: